Raspbian Wheezy armhf Raspberry Pi minimal image

After the Debian Wheezy armel image I made a new one based on Raspbian armhf. This one is compiled with hard float support, so basically floating point operations are MUCH faster because they are done in hardware instead of software emulation :)

Features include:

  • A minimal Raspbian Wheezy installation (similar to a netinstall)
  • Hard Float binaries: floating point operations are done in hardware instead of software emulation, that means higher performances
  • Disabled incremental updates, means apt-get update is much faster
  • Workaround for a kernel bug which hangs the Raspberry Pi under heavy network/disk loads
  • 3.6.11+ hardfp kernel with latest raspberry pi patches
  • Latest version of the firmwares
  • Fits 1GB SD cards
  • A very tiny 118MB image: even with a 2GB SD there is a lot of free space
  • ssh starts by default
  • The clock is automatically updated using ntp
  • IPv6 support
  • Just 14MB of ram usage after the boot

Here is the link to download my custom image:

http://files2.linuxsystems.it/raspbian_wheezy_20140726.img.7z – London, UK
Checksum MD5: 1be9af7fcec38c7238229edf1c5cdb3c

Mirrors:
7zip: md5sum(1be9af7fcec38c7238229edf1c5cdb3c) – File size: 144MB
http://mirrors.node1.hadrill.org.uk/darkbasic/raspbian_wheezy_20140726.img.7z – Amsterdam, Netherlands (1)
https://debianer.puppis.uberspace.de/files/RaspberryPi/raspbian_wheezy_hardfp_20140726.img.7z – Frankfurt, Germany

You will have to extract the image with p7zip:

7za x raspbian_wheezy_20130923.img.7z

Then flash it to your SD with dd:

dd bs=1M if=raspbian_wheezy_20130923.img of=/dev/sdX

Finally, if you have an sd larger than 1GB, grow the partition with gparted (first move the swap partition at the end).

The root password is raspberry.

 

You will have to reconfigure your timezone after the first boot:

dpkg-reconfigure tzdata

The keyboard layout:

dpkg-reconfigure console-data

And the localization:

dpkg-reconfigure locales

 

It’s done, I hope you will enjoy it.

679 comments to Raspbian Wheezy armhf Raspberry Pi minimal image

  • […] Raspbian Wheezy armhf Raspberry Pi minimal image […]

  • darkbasic

    Update:
    – Synced to 2012/06/08
    – Disabled incremental updates, means apt-get update is much faster
    – Workaround for a kernel bug which hangs the Raspberry Pi under heavy network/disk loads.

  • magarcan

    How can I run it, on Qemu?
    Does network work in Qemu?
    Thanks!!

  • drbian

    What do you mean by “Workaround for a kernel bug which hangs the Raspberry Pi under heavy network/disk loads”? Is it something you patched by yourself or is it an “official” push to git?

    • darkbasic

      It’s just a vm.min_free_kbytes directive, otherwise the pi goes OOM and hangs even when there is plenty of memory available.

  • emg

    You have a typo in your keyboard layout command, it should be dpkg-reconfigure console-data. Nice image BTW!

  • ulysess

    What’s the ssh password?

  • ulysess

    Ops, sorry about the last post. Got it.

  • Peter

    Is there an apt repo setup with other packages to install? Would I be able to start an x session with this image?

  • gef

    thanks for the image! not sure if it’s just me, I haven’t used 7z much but on my squeeze box it’s 7zr x to uncompress

  • Fernan

    ssh password??

  • Hadi

    great job! I wanted to have debian with SSH since I have no usb keyboard.

  • stefan

    Is iptables avalible in this image ??

  • stefan

    @darkbasic

    I’m running a small shell server mainly for IRC therefor iptables would be most useful. Thanks for Your great job.

  • Hadi

    would it be possible to publish changes so that we don’t need to re-write SD image?

  • stefan

    That would be suprb.

  • Robert Nix

    Tried to install some packages, and got the following:

    Unpacking libgtk2.0-dev (from …/libgtk2.0-dev_2.24.10-1_armhf.deb) …
    dpkg: error processing /var/cache/apt/archives/libgtk2.0-dev_2.24.10-1_armhf.deb (–unpack):
    corrupted filesystem tarfile – corrupted package archive

    Not sure where to find the person or persons who might care, but thought this might be the place to start….

  • mrlinux2u

    Downloaded this earlier and burnt to a 2gb SDcard, very happy with the results and got my webcam working with motion.

    I’ve only got one question, will rpi-update work with this version or do we to wait until you update the kernel?

    cheers

    • darkbasic

      I never used rpi-update.

    • Robin

      I just tried rpi_update to fetch the latest firmware and it works like a charm. It recognizes the HardFP usage and uses the right libraries.
      Gigantically increased the performance of my SD card.

      Great image by the way, thanks!!

      ——-

      aspberry Pi firmware updater by Hexxeh, enhanced by AndrewS
      Performing self-update
      Autodetecting memory split
      Using ARM/GPU memory split of 224MB/32MB
      We’re running for the first time
      Setting up firmware (this will take a few minutes)
      Using HardFP libraries
      If no errors appeared, your firmware was successfully setup
      A reboot is needed to activate the new firmware

  • stefan

    Hi,

    Just started playing with this build and I have to say it is superb!!! It feels like netinst, no rubbish just a system. If U can add iptables to next version I would be best choice for RPI. It is faster and more stable.
    Thanks.

  • stefan

    update:

    – ntp is working great. uptimed/uprecord problem fixed.
    – swappiness is bit high 60.

  • Big Suzy

    I’ve just installed this with no problems, and it’s great! Just want I’m looking for as the basis for a headless server.

    Many thanks!

  • stefan

    iotop is not working in current build. :)

  • Horrork1d

    Should the average Raspberry Pi user (no Low-Level coding stuff, just some Python and C and Linux ;)) use the armhf or the armel image you made previously? Don’t know the exact differences between both architectures.

    Best regards
    Horrorkid

  • Francesco

    Hi! Any insight on how to correctly run the image under qemu? I have the latest Git verison of Qemu (running under ubuntu) and I’m using cnxsoft zImage (I followed this: http://www.raspberrypi.org/phpBB3/viewtopic.php?f=2&t=3149). Your image starts and reaches the login prompt showing a “(none) login:” (instead of “raspberry-pi login:”) and if I login as root I’m sent back to the login prompt. MAybe the problem is that I’m using a armel kernel on a armhf image?

    Thanks for any help!

    Francesco

  • Thanks for posting this image! I’d like to compile some wireless drivers for my Raspberry Pi. How can I get the kernel source for this image?

    Thanks!

    • Install the build-essential package to have all the needed compilers etc. to build the drivers from source. What wireless card is it? It may have drivers on the manufacturers website, or may just need firmware to be installed from the repository.

    • darkbasic

      I will include the sources in the next version, if you can’t wait you find them in the official site.

  • A very nice lightweight image. There do however seem to be some key utilities missing which I would consider essential really, such as bz2 and less.

  • Rob

    Hi, I am new to Linux and Raspberry Pi and slightly confused. I am not sure how to log into this operating system. I have tried log in as Root, password as Raspberry and then Startx but that doesn’t work. I would appreciate some help please.

    Thanks.

  • darkiceuser

    When your compiling packages for your Raspian repo can you RECOMPILE this one WITH MP3 SUPPORT

    Will need: LAME 3.98+ , libmp3lame0 which from your package list appear to be in the repo already.

    Its really useless with out MP3 support and Debians version as the note below says lacks it for whatever reason, so I’ll take it based on its origins and the lack of libmp3lame0 being listed as a depends it was compiled directly from the Debian version.

    It make life a lot easier for MANY using Darkice to have a repo ready version with MP3 support.

    Look to be trying out your distro shortly for my project.

    Thanks!

    Package: darkice
    Version: 1.0-1
    Architecture: armhf
    Maintainer: Jochen Friedrich
    Installed-Size: 296
    Depends: libc6 (>= 2.13-28), libgcc1 (>= 1:4.4.0), libogg0 (>= 1.0rc3), libstdc++6 (>= 4.4.0), libtwolame0, libvorbis0a (>= 1.1.2), libvorbisenc2 (>= 1.1.2), lsb-base (>= 3.0-6)
    Suggests: darksnow
    Homepage: http://code.google.com/p/darkice/
    Priority: optional
    Section: sound
    Filename: pool/main/d/darkice/darkice_1.0-1_armhf.deb
    Size: 111172
    SHA256: 4775ff7f14829c7e99b7c5058b9900610f98722764ecacdc4f39a42df39b7245
    SHA1: 1d71d56d50575f4399b1268d1ada4b6878b933c0
    MD5sum: 9f1d5305306cbce55b14fea64fbe0449
    Description: Live audio streamer
    DarkIce is an IceCast, IceCast2 and ShoutCast live audio streamer. It
    takes audio input from a sound card, encodes it into mp3 and/or Ogg
    Vorbis, and sends the mp3 stream to one or more IceCast and/or
    ShoutCast servers, the Ogg Vorbis stream to one or more IceCast2
    servers. DarkIce uses lame as a shared object as its mp3 encoder, and
    the Ogg Vorbis as its Ogg Vorbis encoder.
    NOTE: The Debian version of DarkIce is only compiled with Ogg Vorbis
    support due to patent reasons and will therefore only work with IceCast2
    servers

  • dutch_linux

    This images is excellent!
    I just have one question, since I have a 16gb sd card that I use for the r-pi, how can I extend the swap partition? Since we have 256mb Ram, I figured a swap of 512 would be enough.

  • kartolo

    how can I maximize the RAM? the default is 32M for the GPU, how can I lower this even more? 8M or 1M? I want to use it headless, so no GPU will be needed :)

  • […] space. I also want to try and squeeze as much performance as I can out of the device so I found a Raspbian Wheezy armhf minimal image. The image is built with support for hardware floating-point operations and is a very minimal, […]

  • Bob G3WKW

    Thanks for this. I had been trying to run a Ham Radio application WSPR which has a lot of Fortran computations and it was VERY slow under the armel Wheezy build but this runs as fast as a desktop. However I doubt I could have got it running if I had not built the armel version first. Raspberry Pi is a great education!

  • Big Suzy

    I’m having problems getting wifi working. Do I need to recompile the source with the appropriate drivers or am I just missing something obvious?

  • SileNT

    Is nfs server enabled in the kernel? With official raspberry pi debian release I get this:

    Starting NFS common utilities: statd.
    Not starting NFS kernel daemon: no support in current kernel. … (warning).

  • TRAVI5TY

    Thank you for this. I originally installed the basic debian from RaspberryPi.org, and after using your image I can notice the improvements in snappiness. Pretty much everything runs smoother! Thanks again.

  • Izelenn

    Could you provide a hash (md5 or sha1 or something…) of your image ?

  • javaboyuk

    Great!!

    1. Any idea when your next version of the image might be out?

    2. Sorry for the possibly daft question: If I use apt-get to get new packages or updates will they be compatible with this wheezy armhf image or do I need to recompile them to use armhl and get special wheezy code from somewhere else.

    can’t wait for this to become the defacto standard build to run!

  • javaboyuk

    LOL, and then he read the FAQ!
    Great FAQ too good to see it will be Wheezy that will be the official release. But would love to have an idea when your next cut of the image will be tho 😉

  • Rodri

    Thank you! It was bugging me no end that from day one there has been no ‘minimal’ image without bloated gui packages taking up precious space! With this image I can freely choose to set up a truly minimal desktop (using fluxbox for example) or have a clean headless server. This should be the ‘defacto’ image.

  • I’m also in favor of a minimal official image, and darkbasic, I have to say, Great Job with this one!
    I look forward to your next with ip-tables, and just wanted to say keep up the great work, it’s my first time here, and I already know I’m subscribing to your RSS!

  • covex

    Publishing a pratimage archives would save us a lot of dd time to write the data to SD. Well the disadvantage is a windows users will need a livecd to make an SD.:(

  • covex

    One more thing – not all 2GB SD cards have the same capacity, they slightly vary. I won’t fit your image to mine.

  • Colby Shores

    For some reason the apt-get is reporting that the machine is configured for armel(arm v5 instructions, software floating point). This even happeneds after I update the repositories to archive.raspbian.W: Failed to fetch http://archive.raspbian.org/raspbian/dists/wheezy/InRelease Unable to find expected entry ‘main/binary-armel/Packages’ in Release file (Wrong sources.list entry or malformed file)

    I have a feeling this img isn’t built for armhf in mind. Strange.

    Let me know when you get a chance. I like the minimal install you are doing.

    • darkbasic

      The image is armhf indeed (armhf binaries, firmwares and kernel, also it runs armhf binaries). Can you please tell me which command reports arm v5? Maybe there is simply a misconfigured configuration file somewhere…

  • Ryan

    Does this image have support for USB webcams, UVC, etc.?

  • Colby Shores

    apt-get must be borked. I noticed that at first the defaults are pointed over to the archive.raspberrypi.org, i initially did apt-get update not realizing it then noticed it was downloading for armel then switched it to archive.raspbian.org and then did apt-get update and it kicked back that error. Your image is small enough Ill just reimage it and make the appropriate change to apt-get sources list.
    -hellguide

  • Colby Shores

    Weird i went and ref lashed it and and it looks like I must have pulled the wrong image since now it is pulling armhf debs.

  • xcooling

    few suggestions for the next build:

    set /sys/block/mmcblk0/queue/scheduler to noop
    set noatime,nodiratime to /
    vm.swappiness = 10

  • ferrymanr

    I notice that on raspberrypi.org there was an announcement on Thursday 12th. of an upcoming official release of raspbian. It will be interesting to see if wspr works on there. Tonight I’m trying to install wspr on the rpi_pisces_r3.img dated 10/7/2012 where hardfloat seems to work OK.
    Dick

    • Bob G3WKW

      I have wspr working fine on this build in the GUI version and have modified the nogui version to give a more user friendly output via SSH. Thinking hard about modifying the nogui to have a web interface so that config can be changed and perhaps watch the waterfall. The hardfloat was definitely needed. With the nogui it is possible to set it running and then leave it in headless mode.

      Bob
      G3WKW

  • Nacho

    Hi.

    This version resolves problems downloading Torrents using Transmissions?

  • Nacho

    Yes, It’s about that problem.

    This is the issue:

    http://www.raspberrypi.org/phpBB3/viewtopic.php?t=6958&p=121758

    I’ll test your version and I let know the result.

    Thanks.

Leave a Reply

  

  

  

You can use these HTML tags

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>